This board is the new home for david63's extensions.

All of the extensions hosted here will need to be treated as a new install as there is no migration from the original ones to these, and furthermore, no support will be given to migrating to any of these extensions from previous versions.


Due to the selfishness of certain board members it has become necessary to apply a limit of how many downloads each member can make before making a donation. Once a donation has been made then you will have unlimited downloads.

[3.3.0] User Defaults

Fully working extensions
User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

[3.3.0] User Defaults

#1

Post by devspace »

New User Default Settings:

Allows an Admin to set the default user settings for new users.

Compatibility:

Image Image

Image

Notes:

If you are using any other version of this extension then it must be Disabled /Delete data and the original files deleted before installing this version - you will loose all settings.

Features:
  • Can set User Profile settings.
  • Can set notification settings to be email in addition to notification
Language(s):
  • en
Version:
  • 3.3.0
Installation:
  • Download the latest release and unzip it.
  • Upload the unzipped files to [board root]/ext/devspace/userdefaults and enable it in the ACP
Configuration:
  • ACP
  • Extensions
  • User defaults
  • Manage settings
Extension Download:

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

User Defaults

#2

Post by devspace »

Announcements:

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#3

Post by stone23 »

The file I downloaded from this extension contains errors in compser.json!
Since I can no longer download, could you have the correction to give me what I must replace with this code which is the cause of my worries because of this file:

Code: Select all

     	},
		"version-check": {
        	"host": "version.phpbbdev.space",
        	"directory": "/versions/devspace",
        	"filename": "user_defaults_version_file.json",
			"ssl": true
Before asking people to pay to download it would be good to provide CORRECT files!!!

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

Re: [3.3.0] User Defaults

#4

Post by devspace »

stone23 wrote: 17 Jan 2023, 20:47
The file I downloaded from this extension contains errors in compser.json!
That is not true. If there were any "errors" in a composer.json file then that file would not even load - but I would be interested to know what you believe to be the error as that is standard phpBB code as defined here and can be found in all validated extensions.

What I might be willing to accept is that for some reason your server/host/firewall is blocking access to these files.

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#5

Post by stone23 »

So how do you explain that since I deleted these lines which are used to control the version on YOUR SERVER, the extension works perfectly but can no longer control if the version is up to date?

HiFi Kabin
Member
Member
Posts: 21
Joined: October 2022

Re: [3.3.0] User Defaults

#6

Post by HiFi Kabin »

It works perfectly well for me so I would suggest that there is either something in your .htaccess file (as mentioned above) or your servers configuration that is causing the error.

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#7

Post by stone23 »

David63 had answered me this:
david63 wrote: 13 Jan 2023, 12:44
That error was caused by having to move servers and I believe has now been fixed with the downloads from here.
That's what makes me think that the version control settings may need to be fixed.

I have 86 extensions activated on my forum and it's increased to more than 100 extensions activated and I've never had any 504 error problems...

User avatar
[Dimetrodon]
Donor
Donor
Posts: 26
Joined: October 2022

Re: [3.3.0] User Defaults

#8

Post by [Dimetrodon] »

stone23 wrote: 18 Jan 2023, 10:06
David63 had answered me this:
david63 wrote: 13 Jan 2023, 12:44
That error was caused by having to move servers and I believe has now been fixed with the downloads from here.
That's what makes me think that the version control settings may need to be fixed.

I have 86 extensions activated on my forum and it's increased to more than 100 extensions activated and I've never had any 504 error problems...
David63 believes there is something on your server blocking access to the version control file. Regardless if what was previously stated, a new download will NOT solve your problem.

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#9

Post by stone23 »

But I no longer have the problem since by removing the version check code from the composer.json file the extension works perfectly even though I haven't changed anything on my server or on my htaccess file...
And since then, I have tested to put the codes in question and the exension still works....
Amazing, right?

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

Re: [3.3.0] User Defaults

#10

Post by devspace »

stone23 wrote: 18 Jan 2023, 14:45
But I no longer have the problem since by removing the version check code from the composer.json file the extension works perfectly even though I haven't changed anything on my server or on my htaccess file...
And since then, I have tested to put the codes in question and the exension still works....
Amazing, right?
Let me see if I understand this.

You removed the version check code from the composer.json file and you did not get the 504 error (that I can understand) and then you added the code back to the composer.json file and still did not have the 504 error.

Is that correct?

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#11

Post by stone23 »

Yes, that's it.

After removing those version control lines, all 3 extensions I downloaded worked with a banner that said version control was no longer available.
I then put back the original compser.json files for the extensions and they now work normally.

And I haven't changed anything, neither on my forum, nor on my server...

So I don't understand why this happened.

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

Re: [3.3.0] User Defaults

#12

Post by devspace »

stone23 wrote: 19 Jan 2023, 15:48
So I don't understand why this happened.
Neither do I and nothing has changed at this end

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#13

Post by stone23 »

Hello,
Since updating phpBB to version 3.3.10, I get 504 errors again...
Only the "Log Search" extension seems to work...
An idea ?

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#14

Post by stone23 »

Hello,
I reinstalled the extension and I get the same behavior as in this post on the Forum Subs extension: viewtopic.php?p=450#p450

In addition, I also have this weird behavior and I can't find the text in the extension's translation files:
ScreenShot037.jpg
Can you explaine to me ?
You do not have the required permissions to view the files attached to this post.

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#15

Post by stone23 »

The error was already present with the extension by David63:

Image

Can you explain to me ?

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#16

Post by stone23 »

stone23 wrote: 03 Apr 2023, 20:16
The error was already present with the extension by David63:

Image
Can you explain to me ?

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

Re: [3.3.0] User Defaults

#17

Post by devspace »

stone23 wrote: 03 Apr 2023, 20:37
stone23 wrote: 03 Apr 2023, 20:16
The error was already present with the extension by David63:

Image
Can you explain to me ?
As has been stated many times there is no support here for david63's extensions.
stone23 wrote: 03 Apr 2023, 19:26
In addition, I also have this weird behavior and I can't find the text in the extension's translation files:
That text comes from phpBB's core language files

Please note that posting the same question twice in 20 minutes will not achieve anything.

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#18

Post by stone23 »

devspace wrote: 04 Apr 2023, 17:56
As has been stated many times there is no support here for david63's extensions.
You make no effort to understand what I'm trying to tell you...

I wanted to point out that the error already existed on the extension of David63 but you took over the development of this one and did not correct this error since it is still present on your extension!

My question asked here: viewtopic.php?p=452#p452 is about your extension!!!

You only answer what suits you !

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

Re: [3.3.0] User Defaults

#19

Post by devspace »

stone23 wrote: 04 Apr 2023, 18:31
You only answer what suits you !
I try to answer the questions you ask but obviously something is getting lost in translation and/or understanding.
stone23 wrote: 04 Apr 2023, 18:31
You make no effort to understand what I'm trying to tell you...
I would beg to differ _ I try to understand but to be honest I have no idea what you are doing.

You post errors from david63 extension but say that has nothing to do with the problem. You say you have changed code in the extension and the problem went away then it came back. You say that it is nothing to do with your server, yet nobody else has reported this as a problem. Even though there are errors you say there is nothing in the server error log that might give a clue as to what the problem may be.

I have said over again that there would appear to be some problem with your board/server/host setup that is unique to you, but I do not know what that could be. To repeat yet again - there appears to be something on your server/host that is preventing outgoing requests.

HiFi Kabin
Member
Member
Posts: 21
Joined: October 2022

Re: [3.3.0] User Defaults

#20

Post by HiFi Kabin »

php 7.1 33 and 8.2.0 with phpBB 3.3.10
screenshot_58.png
therefore it has to be your setup as has been said many times before
You do not have the required permissions to view the files attached to this post.

GanstaZ
Member
Member
Posts: 11
Joined: October 2022

Re: [3.3.0] User Defaults

#21

Post by GanstaZ »

One of the issues he is having - "Allow users to send you private messages" is displayed twice.
stone23 wrote: 04 Apr 2023, 18:31
I wanted to point out that the error already existed on the extension of David63 but you took over the development of this one and did not correct this error since it is still present on your extension!
Error can't be the same.. Because vendor is not david63 anymore.
That check can be turned off, but it wont fix the root issue.. only hide it.

HiFi Kabin
Member
Member
Posts: 21
Joined: October 2022

Re: [3.3.0] User Defaults

#22

Post by HiFi Kabin »

@Stone

Did you remove David63's extension properly? (ie disable, delete data, delete files) Looking at the screenshot again it appears to be referencing both versions which sort of implies that both are still there

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#23

Post by stone23 »

HiFi Kabin wrote: 05 Apr 2023, 15:33
@Stone

Did you remove David63's extension properly? (ie disable, delete data, delete files) Looking at the screenshot again it appears to be referencing both versions which sort of implies that both are still there
The screenshot shown Here was captured on a test forum to show the language keys error, and since these are phpBB's language files, that means there is a language key issue at the extension level and it is possible that no one has noticed the problem!

But Devspace's evasive answers exasperate me because they just keep repeating the same thing over and over to me from the start!!!

stone23
Donor
Donor
Posts: 75
Joined: January 2023

Re: [3.3.0] User Defaults

#24

Post by stone23 »

devspace wrote: 04 Apr 2023, 21:09
stone23 wrote: 04 Apr 2023, 18:31
You only answer what suits you !
I try to answer the questions you ask but obviously something is getting lost in translation and/or understanding.
stone23 wrote: 04 Apr 2023, 18:31
You make no effort to understand what I'm trying to tell you...
I would beg to differ _ I try to understand but to be honest I have no idea what you are doing.

You post errors from david63 extension but say that has nothing to do with the problem. You say you have changed code in the extension and the problem went away then it came back. You say that it is nothing to do with your server, yet nobody else has reported this as a problem. Even though there are errors you say there is nothing in the server error log that might give a clue as to what the problem may be.

I have said over again that there would appear to be some problem with your board/server/host setup that is unique to you, but I do not know what that could be. To repeat yet again - there appears to be something on your server/host that is preventing outgoing requests.


I'LL GIVE IT TO YOU IN YOUR LANGUAGE, SINCE YOU VISIBLY DON'T UNDERSTAND WHAT I'M SAYING!


ScreenShot043.jpg
ScreenShot042.jpg
ScreenShot041.jpg

I CANNOT PUT ANY MORE FILES 0 CAUSE OF YOUR RESTRICTIONS 0 THE FUCK THAT WORKS OUT FOR YOU BUT I STILL WAIT FOR EXPLANATIONS ABOUT YOUR EXTENSIONS THAT CAUSE ME THESE ERRORS AND WHICH ARE THE ONLY 0 DO IT!!!
You do not have the required permissions to view the files attached to this post.

User avatar
devspace
Owner
Owner
Posts: 279
Joined: October 2022

Re: [3.3.0] User Defaults

#25

Post by devspace »

With regard to the perceived language key issue I apologise as I did not realise what the problem was at first - especially as you were asking where the language definitions were in the extension. This would appear to be a bug that has been there possibly for ever. In actual fact it does not affect anything.